xfce 64bit compile problems

Joshua Jensen joshua at iwsp.com
Thu Nov 10 23:16:20 CET 2005

I've got the src rpms from http://www.xfce.org/archive/xfce-,
and I'm having some problems compiling them on Red Hat Enterprise Linux
4 for EM64T/Opteron.  For several of the packages that require
startup-notification, I get this error message during compile:

$ gcc -O2 -g -pipe -m64 -Wl,-O1 -o xfcalendar xfcalendar-about-xfcalendar.o xfcalendar-callbacks.o xfcalendar-interface.o xfcalendar-main.o xfcalendar-mainbox.o xfcalendar-reminder.o xfcalendar-support.o xfcalendar-tray_icon.o xfcalendar-xfce_trayicon.o -Wl,--export-dynamic -Wl,-R/usr/lib64  -L/usr/X11R6/lib64 /usr/lib64/libxfcegui4.so -lstartup-notification-1 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgmodule-2.0 -ldl /usr/lib64/libdbh.so -lm /usr/lib64/libxfce4mcs-client.so -lSM -lICE -lX11 /usr/lib64/libxfce4util.so -lgobject-2.0 -lglib-2.0
/usr/bin/ld: cannot find -lstartup-notification-1
collect2: ld returned 1 exit status
make[2]: *** [xfcalendar] Error 1

I really do have startup-notification installed, I promise:

# ldconfig -v | grep startup-notification
        libstartup-notification-1.so.0 -> libstartup-notification-1.so.0.0.0
        libstartup-notification-1.so.0 -> libstartup-notification-1.so.0.0.0

# rpm -q startup-notification

I'm compiling for 64bits, so I've tried removing the i386 package and
re-running ldconfig, but I still get the same failure.  I've removed 
both, added them either or both back... same problem.

Anyone have any ideas?

Joshua Jensen
joshua at iwsp.com
"If God didn't want us to eat animals, why did he make them out of meat?"

More information about the Xfce4-dev mailing list