Xffm and Samba 3.014a and Japanese

Edscott Wilson Garcia edscott at xfce.org
Mon May 23 17:13:02 CEST 2005

El lun, 23-05-2005 a las 22:40 +0900, Daichi Kawahata escribió:
> On Wed, 18 May 2005 11:28:09 -0500
> Edscott Wilson Garcia wrote:
> > > P.S. I've installed samba 3.0.14a finally, will report encoding
> > > related problem if it exists.
> > 
> > Also, please check for local file management:
> > duplicate, symlink, creating new files/directories with
> > japanese names.
> > 
> > Are the new files accessible from xffm? Are they accessible
> > from terminals? 
> Last weekend, I had tried those tests but Japanese itself wasn't
> displayed correctly at first place (both of UTF-8, EUC-JP names
> were illegally converted, or didn't appear at all), what I tried
> at smb.conf were as follows,
>     unix charset = EUC-JP/UTF-8
>     dos charset = CP932
>     display charset = CP932
> but as far as I had searched, I guess the problem is in Samba 3.x
> itself.

OK. Thanks for the tests.

> Then, here's an another problem that if I put EUC-JP or UTF-8 file
> into the home directory, one of xffm related modules crashes (not
> total crash). Too bad, attached stack trace log seems quite useless
> in this case and I couldn't make sure what caused it actually.

If you use the option "--enable-debug=yes" at configure time, then the 
modules will be dynamically linked any you will get a usefull debug
traceback. If you continue to get a crash without debug information,
then the problem is with a plugin (highly unlikely on startup) and you
can remove the plugins from your installation directory one-by-one to
find out which one is the problem.

I cannot reproduce the problem here. EUC-JP files show fine in the home
directory at startup (

> Also it might not be related encoding issue, when I re-sized & exited &
> restarted xfce4-fm, it doesn't show icons at home directly, seems to
> cause hang or the like. It's difficult to explain, but when I moved
> to another directory from the home, it shows icons ordinary ...
> All thing had happened under

Try this again with Several things have changed recently with
respect to restoring the iconview geometry according to the selected
directory, maybe the problem is fixed. If problem remains, then the irix
gtk is working differently and we must force an expose event callback.
Does the problem happen with all directories where you have specifically
resized the window?



Edscott Wilson Garcia <edscott at xfce.org>

More information about the Xfce4-dev mailing list