another panel update

Jasper Huijsmans jasper at
Mon May 9 21:08:16 CEST 2005

Brian J. Tarricone wrote:
> Hash: SHA1
> Brian J. Tarricone wrote:
>>Jasper Huijsmans wrote:
>>>>hey all,
>>>>fyi, from the commit log:
>>>>* remove builtin launcher
>>>>* replace with new launcher (backwards compatible)
>>>>* remove popup position global option
>>>>* other stuff (it's a pretty big change, so I'm sure i forgot something ;-)
>>>>Please tell me if it breaks anything.
>>Unfortunately it breaks *everything* here =/.  It just hangs on startup;
>>no window or anything.  strace shows its in a loop polling fd 3 for
>>data, which it does seem to get every now and then, but goes back into
>>looping.  The main window never appears.
>>I moved aside ~/.config/xfce4/panel to get a fresh start, but the same
>>thing happened.
>>Backtrace isn't all that useful:
>>Program received signal SIGINT, Interrupt.
>>[Switching to Thread -1218603344 (LWP 1595)]
>>0xffffe410 in __kernel_vsyscall ()
>>(gdb) bt
>>#0  0xffffe410 in __kernel_vsyscall ()
>>#1  0xb77ad72d in poll () from /lib/
>>#2  0xb79a6246 in g_main_context_acquire () from /usr/lib/
>>#3  0xb79a650e in g_main_loop_run () from /usr/lib/
>>#4  0xb7dda60c in gtk_main () from /usr/lib/
>>#5  0x080549fa in main (argc=1, argv=0xbfffed64) at main.c:487
> Some more info...
> I tried removing the panel-plugins directory, so it would only have the
> stock included plugins.  Still hung.
> Reverted to SVN revision 14204 (before your big change), and... it's
> still locking up.  This really makes no sense.  Any thoughts, or am I
> b0rked?

I would have guessed your mailwatch plugin, but you have already tried 
removing that. I don't see how my changes could have this effect and it 
seems to work for others. The backtrace is not very helpful. I hate to 
say it, but it looks like you are b0rked :(

More information about the Xfce4-dev mailing list