xfce-mcs-manager broken in CVS

Benjamin Rich benjamin.rich at gmail.com
Tue Sep 7 12:31:13 CEST 2004

Haven't written to this list much, I was just wondering if someone
could illuminate me on a problem.

I've been having problems with xfce-mcs-manager for about a week,
since just prior to xfce.org and the xfce cvs server going down.
xfce-mcs-manager won't run - causing themes in xfce and nautilus etc.
to be wrong, the taskbar to be too wide, screen resolution wrong,
panel wrong size, etc etc - and when I run it manually within xfce
from a console, I get this output:

The program 'xfce-mcs-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
 (Details: serial 91 error_code 2 request_code 157 minor_code 2)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

Occassionally, my panel et al will also freeze when xfce starts, and
re-running them can elicit the same error message, but the panel will
still almost always continue to run anyway.

These problems started when I reset my machine about a week ago to
replace my 17" monitor with a 19" one. I suspected that maybe
something was wrong with X, or that some part of xfce had information
about the monitor and resolution hard-coded in it and was mucking up -
but about 5 or 6 recompiles over the last week have proved that this
can't be the case. I even recompiled X, and then xfce from cvs, but
still xfce-mcs-manager isn't working.

Would anyone have any idea why this might be happening? I'm not using
old code - I've updated and recompiled from CVS before and after the
cvs server went down, and I recompiled about 1hour before sending this
message and things are still not working properly.

I'm running Gentoo, with a kernel with mm and ck patches, Xorg
6.7.0 (gentoo revision 2), xfce straight from cvs, with rox-filer in
the background as a pinboard, and gkrellm 2.2.2.  Everything is
working fine *except* for the mcs manager.

Thankyou for any help anyone can give me on this.

Linux - because a PC isn't just for christmas

More information about the Xfce4-dev mailing list