Xfhelp 4.2 fails in default setting

Jasper Huijsmans jasper at xfce.org
Sun Oct 10 19:11:13 CEST 2004

purslow at sympatico.ca wrote:
> 041010 purslow at sympatico.ca wrote:
>>continuing to explore 4.2 in the interest of QA,
>>i tried 'help' in the desktop menu.
>>when nothing happened, i tried the command 'xfhelp4' from a terminal & got :
>>  purslow: desktop> xfhelp4
>>    No running windows found
>>    Error: No running window found.
>>this is the result of its trying to start Mozilla (or Firefox):
>>when i set  BROWSER=galeon  (or 'lynx' or 'konqueror') help starts correctly.
> the problem is the line(s) later in the script, ie
>   case $BROWSER in
>     firefox*)
>       $BROWSER -a firefox -remote openurl\("file://$URL",new-window\) || \
>         $BROWSER "file://$URL"
> when i enter that command filled out :
>   firefox -a firefox -remote openurl\("file//<helppath>",new-window\)
> i get the error described above.  if i enter :
>   firefox "file:///usr/local/share/xfce4/doc/C/index.html"
> i get the msg "No running windows found", but Firefox does open the dox.
> why does the script call up this long command ?

Because that's the way the default firefox install works (and mozilla, 
and netscape). Apparently your distribution has changed the firefox 
script to already try running a default installation. Unfortunately it 
apparently also return 0 when that command fails. That sounds like a bug 
in your distributions packaging.

>  2  things seem needed to make the script failsafe:
> (1) to add 'lynx' to the list of browsers (usually installed, reliable);

I don't think so. Let's stick with graphical clients only. xfhelp4 will 
print a message when the command fails (except for commands that return 
0 on failure...).

> (2) to make any error in opening a browser cause the script
> to go back & try the next one on the list; alternatively,
> if  BROWSER  is not defined, it cd ask the user to name his/her preference.

Please try typing full words. If you want to send a patch for that I'd 
consider it. Asking for the command cannot be done without additional 
external dependencies, so that is probably out of the question.


More information about the Xfce4-dev mailing list