Benedikt Meurer benedikt.meurer at unix-ag.uni-siegen.de
Sun Mar 21 19:06:49 CET 2004


I tried to hunt the xterm+xfce4-session+linux problem today, but 
unfortunately, I'm still unable to reproduce the bug. It seems to work fine 
even on Linux systems.

I tried to reproduce using the following shell script:

while test ! -f /tmp/foo; do xterm -e 'sh -c exit' & done

All I got from it was a quite unusable X server, but once I touched /tmp/foo, 
everything went back to normal behaviour. Tested with FreeBSD 5.2.1, NetBSD 
1.6W and a gentoo linux box.

Looking at the xfce4-session code over and over again, I can't seem to find 
any bug (seems to be a race cond from what you reported) that could cause such 
weird behaviour (though its usual, that such bugs are found when you don't 
expect it).

Therefore: Can you still reprocude the bug with the current xfce4-session? Is 
there any good chance to get a core dump or any other useful information that 
would help to trace the problem?


NetBSD Operating system:                       http://www.NetBSD.org/
pkgsrc "Work in progress":                  http://pkgsrc-wip.sf.net/
XFce desktop environment:                        http://www.xfce.org/
German Unix-AG Association:                   http://www.unix-ag.org/
os-network:                                 http://www.os-network.de/

OpenPGP Key: http://www.home.unix-ag.org/bmeurer/#gpg

More information about the Xfce4-dev mailing list