a bit futher now but still problems!

edscott wilson garcia edscott at imp.mx
Fri Jan 17 15:21:16 CET 2003

El vie, 17-01-2003 a las 04:51, Didier Wiroth escribió:
> Hey,
> (*NIX newbie)
> I'm using FreeBSD 4.7-RELEASE!
> I've installed the latest gnu autoconf automake and libtool and 
> xfce-devel-snapshot-20030117
> Now, I was able to compile libxfcegui4! (a good starter :-))

Hey, that's good news! I'm going to give it another try now with

> But compiling libxfce4mcs fails with the following output:
> -Wp,-MD,.deps/libxfce4mcs_manager_la-mcs-common.TPlo  -fPIC -DPIC -o 
> .libs/libxfce4mcs_manager_la-mcs-common.lo
> mcs-common.c:28: X11/Xlib.h: No such file or directory
> mcs-common.c:29: X11/Xmd.h: No such file or directory
> In file included from mcs-common.c:36:
> mcs-common.h:29: X11/Xlib.h: No such file or directory
> gmake[2]: *** [libxfce4mcs_manager_la-mcs-common.lo] Error 1
> gmake[2]: Leaving directory 
> `/usr/home/dda/download/xfce-devel/libxfce4mcs/libxfce4mcs'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/usr/home/dda/download/xfce-devel/libxfce4mcs'
> gmake: *** [all] Error 2
> It can't find the files Xlib.h and Xmd.h I assume?! They are located here:
> /usr/X11R6/include/X11/Xlib.h
> /usr/X11R6/include/X11/Xmd.h
> So I tried ./configure --x-includes=/usr/X11R6/include
> or
> ./configure --x-includes=/usr/X11R6/include/X11
> but compiling afterwards fails with the same error output!
> What do I have to modify?!

This looks like a "configure" bug, which should determine where the
header files are located and build a makefile accordingly. The easiest
way you can get it to compile is to edit the problem Makefile.am (there
may be more than one) and add to compile specifications a "-I


> Many thanks
> Didier
> _______________________________________________
> Xfce4-dev mailing list
> Xfce4-dev at moongroup.com
> http://moongroup.com/mailman/listinfo/xfce4-dev

More information about the Xfce4-dev mailing list