[Xfce4-commits] [panel-plugins/xfce4-hardware-monitor-plugin] branch master updated (94371b8 -> 3218e66)
noreply at xfce.org
noreply at xfce.org
Sun Jul 17 18:19:39 CEST 2016
This is an automated email from the git hooks/post-receive script.
omegaphil pushed a change to branch master
in repository panel-plugins/xfce4-hardware-monitor-plugin.
from 94371b8 Addition of CentOS spec file courtesy of Sal Tepedino
adds 553d0f9 WIP prior to porting to GtkBuilder
adds 3db0a91 Port of UI from libglade to GTKBuilder, basic UI addition of Disk Stats monitor
adds 2dbb964 Initial implementation of DiskStatsMonitor
adds fc292ea Validate input before creating new monitors
adds 696cfb0 Remove load method from monitors - all state should be set through constructor, load_monitors is the main place
adds 16a0c6a Implement Generic Monitor
adds 3f0e1d9 Fix duplicate column packing in disk_stats_device_combobox widget
adds b35a71b Standardise how enums are loaded/treated
adds e966062 Remove TODO
adds 3f5b6f9 Some extra debugging code
adds f36a297 Rename applet to plugin now that its no longer a GNOME applet
adds 418c3bc Remove old FSF address
adds 7191fec Fix CurveView text overlay control sensitivity
adds 26575da Small change clearing up any GPL version ambiguity
adds e72c2f9 Remove unused original main file
adds c51712f Ensure DiskStatsMonitor intialises max_value
adds 9c8b4e9 Update Debian dependencies - no libglade, libgtkmm to v2.24
adds 7ab96aa Rename applet to plugin now that its no longer a GNOME applet - missing files
adds 154cb05 Fiddle with '>>' use in container declarations for older compilers Turns out that '>>', e.g. in:
adds 3218e66 Fix enum value namespace problem with older GCC
No new revisions were added by this update.
Summary of changes:
README | 8 +-
configure.ac | 5 +-
debian/control | 8 +-
debian/copyright | 2 +-
m4/libtool.m4 | 2521 +++++++++++++++++++--------------
m4/ltoptions.m4 | 127 +-
m4/ltsugar.m4 | 7 +-
m4/ltversion.m4 | 12 +-
m4/lt~obsolete.m4 | 7 +-
module.xml | 2 +-
po/POTFILES.in | 6 +-
src/Makefile.am | 6 +-
src/bar-view.cpp | 24 +-
src/bar-view.hpp | 4 +-
src/canvas-view.cpp | 28 +-
src/canvas-view.hpp | 4 +-
src/choose-monitor-window.cpp | 695 +++++++--
src/choose-monitor-window.hpp | 115 +-
src/column-view.cpp | 20 +-
src/column-view.hpp | 4 +-
src/curve-view.cpp | 44 +-
src/curve-view.hpp | 4 +-
src/flame-view.cpp | 20 +-
src/flame-view.hpp | 4 +-
src/gui-helpers.cpp | 48 +
src/gui-helpers.hpp | 24 +-
src/helpers.cpp | 6 +-
src/helpers.hpp | 4 +-
src/i18n.hpp | 4 +-
src/main.cpp.old | 77 -
src/monitor-impls.cpp | 780 ++++++++--
src/monitor-impls.hpp | 127 +-
src/monitor.hpp | 11 +-
src/pixbuf-drawing.hpp | 4 +-
src/{applet.cpp => plugin.cpp} | 244 ++--
src/{applet.hpp => plugin.hpp} | 24 +-
src/preferences-window.cpp | 108 +-
src/preferences-window.hpp | 14 +-
src/register_plugin.c | 12 +-
src/text-view.cpp | 10 +-
src/text-view.hpp | 4 +-
src/ucompose.hpp | 4 +-
src/{ui.glade => ui-libglade.glade} | 214 ++-
src/{ui.gladep => ui-libglade.gladep} | 0
src/ui.glade | 1970 ++++++++++++++++----------
src/value-history.cpp | 8 +-
src/value-history.hpp | 4 +-
src/view.cpp | 8 +-
src/view.hpp | 12 +-
49 files changed, 4831 insertions(+), 2567 deletions(-)
create mode 100644 src/gui-helpers.cpp
delete mode 100644 src/main.cpp.old
rename src/{applet.cpp => plugin.cpp} (73%)
rename src/{applet.hpp => plugin.hpp} (90%)
copy src/{ui.glade => ui-libglade.glade} (93%)
rename src/{ui.gladep => ui-libglade.gladep} (100%)
--
To stop receiving notification emails like this one, please contact
the administrator of this repository.
More information about the Xfce4-commits
mailing list