[Xfce4-commits] <tumbler|tumbler-0.1.0> Creating annotated tag tumbler-0.1.0

Jannis Pohlmann noreply at xfce.org
Mon Dec 7 13:12:02 CET 2009


Updating annotated tag refs/tags/tumbler-0.1.0
     as new annotated tag
         to e5ae6be9972570f5a5836548dda71afcee1d8ba2 (tag)
  tagged by Jannis Pohlmann <jannis at xfce.org>
         on 2009-12-07 12:08 +0000

Carles Muñoz Gorriz (1):
      l10n: Initial catalan (ca) translation.

Harald Servat (2):
      l10n: Updates to Catalan (Valencian) (ca) translation
      l10n: Updates to Catalan (Valencian) (ca) translation

Iñigo Varela (2):
      l10n: Updates to Asturian translation
      l10n: Updates to Asturian (ast) translation

Jannis Pohlmann (126):
      Add AUTHORS file.
      Initial import. Nothing useful yet.
      Add tumbler class skeletons and .pot file.
      Implement manager D-Bus interface in TumblerManager.
      Introduce interfaces and classes for built-in thumbnailers.
      Improve TumblerThumbnailer and add TumblerSpecializedThumbnailer.
      Implement thumbnailer management in TumblerRegistry.
      Make the registry thread-safe using a GMutex.
      Implement tumbler_manager_get_supported() based on the registry.
      Use GdkPixbuf to get MIME types for the (optional) pixbuf thumbnailer.
      Add TumblerScheduler and TumblerThresholdScheduler skeletons.
      Implement tumbler_service_start(), add D-Bus bindings for the service.
      Implement tumbler_service_queue() based on TumblerSchedulerRequest.
      Fix last element not being copied in tumbler_thumbnailer_array_copy().
      Implement TumblerNaiveScheduler and add signals to TumblerService.
      Add tumbler utility library, rename the service to tumblerd.
      Add configure options for thumbnail flavors (normal, large, cropped).
      Disable large thumbnails by default.
      Add error domain, TumblerThumbnailFlavor and thumbnail helper functions.
      Implement the built-in pixbuf thumbnailer (doesn't crop yet), fix bugs.
      Add TODO file.
      Add API docs for tumbler (not tumblerd) using GTK-Doc.
      Add more files to .gitignore.
      Implement the first bits of TumblerThresholdScheduler.
      Add TumblerThumbnailInfo and TumblerThumbnailFormat enum.
      Implement tumbler_service_unqueue(), add tumbler_scheduler_unqueue().
      Improve threshold scheduler, thumbnail info and builtin thumbnailer.
      Add TUMBLER_ERROR_NO_THUMBNAILER error code.
      Remove tumbler-thumbnail.h includes.
      Always pass the length along with TumblerThumbnailer arrays.
      Add TumblerCache service and try to start it at startup of tumblerd.
      Add plugin interface for cache and thumbnailer implementations.
      Update API docs a little bit.
      Minor tweaks. Use TUMBLER_ADD_INTERFACE in pixbuf thumbnailer plugin.
      Fix bug in deallocation of provider infos in TumblerProviderFactory.
      Implement Cleanup, Copy, Move and Delete in cache plugin and service.
      Fix service activation and a DBusGConnection refcount bug.
      No thumbnails for thumbnails. Allow Unqueue in the middle of requests.
      Cleanup, remove private structs and use G_DEFINE_TYPE where possible.
      Build plugins after the library.
      Remove deprecated files.
      Add tumbler_thumbnail_save_file() to save thumbnails from source files.
      Add module description file.
      Change module name to 'tumbler', not 'airconfig'. Thanks, Nick.
      Fix two memory leaks. Cleanup indentations.
      Fix two more memory leeks. According to valgrind there are none left.
      Use org.xfce and /org/xfce prefixes instead of freedesktop ones.
      Rename PixbufThumbnailerThumbnailer to PixbufThumbnailer. More renames.
      Implement the font thumbnailer, reusing code from ThunarVFS.
      Merge strings, update translation files.
      Fix typo. The variable is called pixbuf, not font.
      Fix several mistakes and typos, and therewith make distcheck.
      Simplify the ENABLE_FONT_THUMBNAILER conditional.
      Make the pixbuf support all URI schemes supported by GIO.
      Make the font thumbnailer work with all URI schemes supported by GIO.
      Make sure to free the font file data.
      Always add "file" to the supported URI schemes. Fix compiler warnings.
      Always check for "file" and add it if necessary. Clearly the better way.
      Fix reference counting leak spotted by Philip Van Hoof.
      Derive TumblerSpecializedThumbnailer from TumblerAbstractThumbnailer.
      Register marshallers for specialized thumbnailer signals.
      Chain constructed up to parent classes. Need to remember this.
      Rename D-Bus service file, add others for the cache and the manager.
      Rework build files. Fix bugs introduced in previous commits.
      Minor changes in the configure script.
      Remove xfce4-dev-tools specific code from the neutral autogen.sh.
      Add GdkPixbuf check to the font thumbnailer, add xdg cache macro.
      Use xdg cache macro. Drop revision versioning. Drop MAINTAINER_MODE.
      Fix typo in the cache service file.
      Small parameter name change in the service dbus XML.
      tumbler_scheduler_get_name() returns a gchar *, not a const gchar *.
      Use a GList for managing the schedulers. Rework the service code a bit.
      Update the comments for the LIFO scheduler. Minor coding style changes.
      Rework the TumblerGroupScheduler code. Use a GList for error/ready URIs.
      Back to the org.freedesktop.thumbnails namespace. Use API versioning.
      Update namespace in service files and Makefile.am.
      Fix make distcheck, update translation files, add pot file back.
      Refactor code a bit to make more obvious which scheduler is the default.
      Fix compiler warning, add parameters to uri_error_new().
      Wrap request unqueued check with the mutex to make the check atomic.
      Set background system priority for the group scheduler.
      $(builddir) doesn't work in Maemo scratchbox, using $(top_builddir)
      Make sure to unlock the mutex before returning. Spotted by Philip.
      Fix ifdef. Since we include syscall.h we need to use HAVE_SYSCALL_H.
      Fix memory leak in tumbler_util_get_supported_uri_schemes().
      Optimize tumbler_service_get_supported() by not duplicating strings.
      Cache supported URI schemes and MIME types in the registry.
      Add missing declaration in tumbler-registry.h.
      We need to include unistd.h for the syscall() function.
      Remove TumblerNaiveScheduler.
      Use silent build rules if available.
      Add a few comments, minor coding style changes.
      Cancel all URIs when the GMount they reside in is about to be unmounted.
      Replaced GdkPixbuf APIs with TumblerImageData
      Add TumblerColorspace enum, rename save_pixbuf() to save_image_data().
      Update cache with tumbler_registry_update_supported() only when needed.
      Remove unused function declaration.
      Prepare the API docs for make distcheck.
      Switch to a plugin API that only allows one cache backend at a time.
      Massive refactoring to support flavors properly.
      Remove obsolete provider files. Fix include in tumbler-file-info.c.
      Add missing handle parameter to the declaration of "Ready".
      Rename the delete member of TumblerCache to do_delete (for C++).
      Fix a bunch of compiler warnings.
      Fix gtk-doc (still not up to date though).
      Update translation files.
      Add missing tumbler_plugin_get_cache() function.
      Support specialized thumbnailers and overrides files properly.
      Fix wrong free spotted by Philip.
      Set "modified" of thumbnailers runtime registered to the current time.
      Fix memory leaks in the pixbuf thumbnailer plugin.
      Fix wrong unref in TumblerService. Disconnect from schedulers properly.
      Fix memory leak in the LIFO scheduler.
      Fix two bugs and change debug output.
      Remove empty lists from the hash table when a directory is deleted.
      Fix a few memory leaks.
      Register D-Bus marshallers in _class_init instead of _init.
      Reimplementation of specialized after merge with master
      Fix crash when deleting the last thumbnailer dir/file or overrides file.
      Add missing marshaller.
      Make strings translatable.
      Merge new strings.
      Update API docs (sorta).
      Add Philip to the authors. Update README.
      Add -Wno-sign-compare to the gtk-doc build.
      Release 0.1.0!

Jeff Bailes (1):
      l10n: Add en_GB translation

Leandro Regueiro (3):
      l10n: Created Tumbler galician translation
      l10n: Updates to Galician (gl) translation
      l10n: Updates to Galician (gl) translation

Masato Hashimoto (1):
      l10n: Add Japanese translation

Massonnet Mike (1):
      l10n: Updates to French (fr) translation

Per Kongstad (3):
      l10n: Added Danish translation
      l10n: Updates to Danish (da) translation
      l10n: Updates to Danish (da) translation

Philip Van Hoof (19):
      Prepare build environment for Maemo compatibility
      Put in place dev-tools neutral build environment
      LIFO scheduler for interactive thumbnailing
      Group scheduler for background thumbnailing
      Added `scheduler` parameter to DBus method Queue
      Renamed the kind property to name, using GObject properties
      Fixed a glitch, checking for the wrong function pointer
      Fixed compilation warning
      Moved GetSupported and GetSchedulers to the service
      Add cancel capability to the thumbnail operations.
      Added dbus_message_set_destination to the DBus signal emits
      Add the handle to the Ready signal
      Bugfix emitting error signal
      Do nothing in case of cancelled before we started
      Unqueue is not an English word, Dequeue is.
      Added the DBus API parts for flavor support
      The error-code should be int32, not uint32
      Renamed "Create" to "Queue" in specialized thumbnailer support
      Fixed a bug in the specialized thumbnailer support:

Rihards Prieditis (1):
      l10n: Added Latvian transloation

Samed Beyribey (1):
      l10n: Initial Turkish translation of tumbler

Sergio Marques (1):
      l10n: Added Portuguese translation

Xu Meihong (1):
      l10n: add Simplified Chinese translation

douart patrick (3):
      l10n: New French Translation
      l10n: Updates to French (fr) translation
      l10n: Updates to French (fr) translation




More information about the Xfce4-commits mailing list