xfce4-panel-4.9.0 build failure on FreeBSD 10.0-CURRENT

Conrad J. Sabatier conrads at cox.net
Mon Feb 13 15:17:08 CET 2012

On Sun, 12 Feb 2012 17:47:21 +0900
Andrzej <ndrwrdck at googlemail.com> wrote:

> On 02/12/2012 03:25 PM, Conrad J. Sabatier wrote:
> > Just tried compiling xfce4-panel-4.9.0, but got a failure in
> > plugins/clock/clock.c, due to the lack of the type "sigval_t", which
> > FreeBSD does not define in either<signal.h>  or<sys/signal.h>.
> AFAIK this has been fixed in git master (commit 
> 9430906f6d82f5d66e835b8e924ff8beed58d109):
>   static void
> -clock_plugin_timeout_expired (sigval_t info)
> +clock_plugin_timeout_expired (union sigval info)
>   {
>     ClockPluginTimeout *timeout = info.sival_ptr;
> Andrzej

Hmmm.  I'm thinking maybe I have some old cruft lying around here
that's badly in need of updating that I've overlooked.  I just came
across one of them when I tried to update xfce4-settings.  My libexo
was still at 0.6.2.  Updating right now.

Hopefully, I'll iron this problem out.  It did seem odd to me that that
fix (with union sigval) still resulted in a crashing clock applet.

I'll work on it and report back later.  Thanks!

Conrad J. Sabatier
conrads at cox.net

More information about the Xfce mailing list