installed gvfs, still no trash can

walter tallent w41t3r at
Mon Apr 25 15:26:42 CEST 2011

I guess I'm the only guy on earth with this particular problem, so it must be 
something else in my system.
What version of D-Bus is the recommended version?  I have 1.4.6 installed, could 
that be too new?

From: walter tallent <w41t3r at>
To: xfce at
Sent: Thu, April 21, 2011 10:16:59 AM
Subject: installed gvfs, still no trash can

Still working on that missing trash can issue...
Here's what I've tried so far to enable the trashcan:
Installed gvfs 1.6.7.
Rebuilt Thunar, configure script says trash panel applet will be built.
I see it being built during compilation. (thunar-tpa-la)
Rebuit xfce4-panel.
Rebuilt xfce4-desktop, just for good measure.
Restarted xfce.
Still no trashcan on the desktop.
I went to Panel settings, enabled the trashcan applet (which shows the trashcan 
icon, so the icon is not missing), it opens a spot on the panel with no icon, 
and shows the message "Failed to connect to the Trash: Operation not supported" 
when clicked.

Further investigating shows that gvfsd is not being installed, though it is 
built.  When I tried for kicks to run it manually, it says it  cannot connect to 
the D-BUS daemon, which is running according to ps.  I mention this because the 
gvfs trash backend is part of the gvfsd programs that are not being installed.  
There are no instructions in gvfs files for installing them separate from the 
standard "make install."  Installing gvfs 1.8.0 gives the same results.

When I delete a file from Thunar, it does go into the ./local/share/Trash 
directory, like it's supposed to.  And it adds an entry in the info directory 

Any suggestions?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Xfce mailing list