xfce4 startup appears to override my xmodmap keyboard settings

Chris G cl at isbd.net
Mon Feb 8 19:48:12 CET 2010

On Mon, Feb 08, 2010 at 10:54:55AM -0700, David Mohr wrote:
> On Mon, Feb 8, 2010 at 10:32 AM, Chris G <cl at isbd.net> wrote:
> > On Sun, Feb 07, 2010 at 04:21:46PM -0700, David Mohr wrote:
> >> On Sun, Feb 7, 2010 at 7:15 AM, Chris G <cl at isbd.net> wrote:
> >> > I have a .Xmodmap file which sets up the Compose key and some mouse
> >> > button changes.
> >> >
> >> > Both xfce *and* gdm run 'xmodmap ~/.Xmodmap' for me which is a bit
> >> > redundant but no harm really.  However *only* the mouse settings
> >> > survive through the rest of X initialisation, the Compose key set-up
> >> > for my keyboard is lost.
> >> >
> >> > I have checked pretty carfully and xmodmap is definitely being run (I
> >> > have added echo output at the appropriate places and it appears in
> >> > .xsession-errors, I used to get an xmodmap warning too).  Anyway my
> >> > mouse settings *are* being done so that confirms it's run.
> >> >
> >> > If I run 'xmodmap ~/.Xmodmap' in a terminal window once X is up and
> >> > running I get the keyboard setting I want, so the .Xmodmap file is OK.
> >> >
> >> > My *guess* is that xfce is doing its own keyboard set-up after xmodmap
> >> > is run and overrides the Compose key setting I want.  Is this a bug or
> >> > should I be setting up the Compose key somewhere in the xfce4
> >> > configuration?
> >> >
> >> > For the moment I'm running 'xmodmap ~/.Xmodmap' with a 20 second delay
> >> > from my .xprofile, this works but feels like a bit of a bodge.
> >>
> >> Search the list archives, there has been discussion about this before.
> >>
> > Er, *how* do I search the archives?  There appears to be no search
> > function at http://foo-projects.org/pipermail/xfce/.
> Missing search functionality sucks, that's true. It might be because
> pipermail's search is not good to begin with? Anyone have a clue?
> Anyway, you can always revert to the google, and search for:
>   site:http://foo-projects.org/pipermail/xfce/ xmodmap
The threads that brings up don't sound like the issue that I have,
none of them talk about the xfce keyboard set-up effectively
overwriting what xmodmap has done.  This is almost certainly what is
happening to me IMHO as it makes no difference at all where you run
xmodmap from, if it's run before xfce4 completes its startup then the
keyboard settings are lost.

E.g. if I run xmodmap from my .xprofile I get the mouse set up but
lose the keyboard setup.  If I do *exactly* the same (i.e. run it from
.xprofile) but with a delay then both the mouse setup and the keyboard
setup work.   It has to be something that xfce (or other things that
happen soon after X starts) is doing to the keyboard effectively
overwrites what xmodmap has done.

All the above threads refer to bugs that prevent xmodmap from working
properly, in my case it does work properly but then its work is undone
by something.

Chris Green

More information about the Xfce mailing list