XFCE 4.6.2 stopped working

Grant Edwards grant.b.edwards at gmail.com
Wed Aug 4 23:51:30 CEST 2010

Today for no discernable reason, my window manager vanished.  When I
terminated the X session and did a "startxfce4", the X server started
normally, but the desktop is black and there's no visible mouse cursor.

Doing a "ps" shows the xinit, X server, xinitrc, xfce4-session, but
there is no window manager, panel, or desktop process running.

Running xinit, and then manually starting other window managers works
fine.  If I run xinit manually and then manually start xfwm, it just
sits there hung.  Hitting ctrl-C says this:

  (xfwm4:1549): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

After I terminate X using Ctrl-Alt-Backspace, xfwm is still running,
and I have to do a kill -9 to get rid of it.

I tried creating a new user and using that account with the same

This is an IA32 Gentoo box, that was updated a couple days ago.
Something in the update may have cause the problem, but what?

I've also tried re-emerging all of the XFCE packages, and that had no

How do I go about troubleshooting the lack of wm/panel/desktop?

I've looked in the FAQs and the 4.2 docs but all I can find is info on
how to use XFCE when it's working and not what to do when it stops


More information about the Xfce mailing list