Problem solved

Jerry xfce.user at
Tue Apr 13 19:14:31 CEST 2010

On Tue, 13 Apr 2010 16:51:51 +0200, Ernst W. Winter
<ewinter at> articulated:

> Hello all,
> well since I had not a nswer why I couldn't shutdown xfce4 properly,
> and thans to all that have helped and made suggestions, I have solved
> the problem now with FreeBSD:
> What it is that you start X and all without "hald/dbus and all works
> fine again. Really smooth!!! There is no need to have it and is
> better without it.
> If you wonder why? Here the solution to the problem, a new and
> "FreeBSD Magazine":
> has the solution in the latest issue. Hope that this will help at
> least people that use FreeBSD.

I am presently using XFCE4 on a FreeBSD system, with Hald/DBus enabled
and have not experienced a problem. In fact, I have used XFCE with
FreeBSD for years without any major problems.

Unfortunately, I have not seen this entire thread, so perhaps there is
something I am missing here.

I might ask however; did you post this problem on the appropriate
Hald/dbus forums?

Xfce.user at

Disclaimer: off-list followups get on-list replies or get ignored.
Please do not ignore the Reply-To header.

Never do today what you can put off until tomorrow.

More information about the Xfce mailing list