Seamonkey start problems from menu

John Coppens john at
Sat Jan 26 05:12:28 CET 2008

On Fri, 25 Jan 2008 21:30:44 -0200
John Coppens <john at> wrote:

> > And now... I stare into space for a short while, throw up my hands,
> > and say I have no idea what's goin' on.  Sorry...
> > 
> Could there be any value in changing the startup order of the xfce
> components? Maybe start the desktop last? I'm not even sure if that is
> possible. I'll try to figure out how. Anyway, thanks for the hints,
> Brian!

Again for all:

I tried this:

I killed xfdesktop, and restarted it with exactly the same command line
as the original one (complete with sm-id and all, and left it resident
with &.

It then worked normally, and I could call seamonkey from the menu as
expected. I wonder what this reloading could have as an effect? And how
can I influence on the order of loading at startup?

The original order was:

 3517 tty1     S      0:01 xfwm4 --sm-client-id 11c0a80965000117285707000000044330000 --display :0.0 
 3518 tty1     S      0:00 Thunar --sm-client-id 11c0a80965000117285707000000044330002 --daemon
 3519 tty1     S      0:00 xfdesktop --sm-client-id 11c0a80965000117285707100000044330003 --display :0.0
 3520 tty1     S      0:02 xfce4-panel --sm-client-id 11c0a80965000117285707000000044330001 --display :0.0 
 3521 tty1     S      0:00 orage --sm-client-id 11c0a80965000118817237500000033440508 --display :0.0
 ...followed by the plugins.
 after the desktop restart, it was running as:

 4681 pts/3    S      0:00 xfdesktop --sm-client-id 11c0a80965000117285707100000044330003 --display :0.0

Suggestions? Or should I report this as a bug?


More information about the Xfce mailing list