Dan Coit dan at coitnet.net
Tue Oct 18 01:03:24 CEST 2005

Gentlemen:  I have a strange problem.  Somehow, something from my Ubuntu
Gnome clobbered my xfce4 in such a way that the two were intermingled.
My wallpaper disappeared and right-click to get a menu did nothing.  I
found that by overwriting a backup of
~/.cache/sessions/xfce4-session-XXX.local:0 onto the original restored
my xfce desktop to nearly the same as before.  However the "Quit"
function vis xfsm-shutdown-helper no longer presents a menu to select
"Quit the session," "Reboot..." or "Shutdown ..."  Searching in the
forums, faq's and google refers to changing the /etc/sudoers file adding
a line allowing execution of /usr/sbin/xfsm-shutdown-helper by users
other than root.  But at least in Ubuntu, this line never existed.  I
created a new user as a test then logged in as the new user and selected
Xfce4 as the window environment and found the xfsm-shutdown-helper
worked like a charm as the new user, but still not as the original user.
The line was not appended to /etc/sudoers by the creation of the new
user and the xfsm menu works (for the new user).  Apparently,
the /etc/sudoers line is not needed and apparently there is some file in
the new user's /home directory which permits the xfsm-shutdown-helper
menu.  Any ideas which file is being accessed to permit/disallow the
helper function?  Thanks!
Dan Coit

More information about the Xfce mailing list