xffm: no smbfs support

Edscott Wilson Garcia edscott at xfce.org
Tue May 24 15:26:24 CEST 2005

El mar, 24-05-2005 a las 11:57 +0900, Batara Kesuma escribió:
> Hi,
> When I tried to browse my SMB network, I got the error below:
> No such device:
> no smbfs support detected in kernel
> I run Debian, and I already installed smbfs and smbclient packages. How
> can I fix this? Thank you very much.

That message appear when you try to mount a remote share and mounting
smbfs is broken. 

There is a bug when trying to mount smbshares under solaris, and
apparently the debian kernel is built similar to solaris. That is,
if you look in config.h you will see both HAVE_GETVFSENT, and
HAVE_SYS_STATFS_H are defined.

All I know of Solaris are the following fstab types:

#define MNTTYPE_CACHEFS	"cachefs"
#define MNTTYPE_HSFS	"hsfs"
#define MNTTYPE_NFS	"nfs"
#define MNTTYPE_SWAP	"swap"

If you can tell me what corresponds to a smbfs in fstab, the bug should
be fixed (The entry is probably "smbfs", but I cannot be sure, look at
your man page for fstab)

This only applies to smbfs *not* listed in fstab. If you manually list
the smbshare in /etc/fstab, you should have no problem mounting it.

Edscott Wilson Garcia <edscott at xfce.org>

More information about the Xfce mailing list