Setting environment variables

Bob Hepple bhepple at
Fri Mar 11 21:14:36 CET 2005

Have you tried logging out and then log in again? If it's still a problem
then you need to look at how the X session is started - startx. startxfce4
or xdm/gdm?

Or try starting bash with "-l" option. If you still can't see the
environment variables then there's something wrong in the way the system
starts you up - something in /etc. Maybe you have a /etc/profiles.d
directory or something similar. Or maybe you have a /etc/bash* files.

Every system is a bit different in exactly how it's set up.



On Fri, 11 Mar 2005 21:26:33 +0100
Alexander Toresson <alexander.toresson at> wrote:

> I've been trying to set some environment variables. I've added them 
> to .bash_profile in my home directory, like this:
> PATH=/root/euphoria/bin:$PATH
> EUDIR=/root/euphoria
> BROWSER=dillo
> But it still doesn't work! The xfce help complains that it cannot find
> any browser, and the euphoria programming language cannot find its
> include files. I've also added the environment vars to my .bashrc,
> with no success. I also cannot see them in any console or console 
> emulator by typing "set|more".
> What am I doing wrong?
> Regards, Alexander Toresson
> _______________________________________________
> Xfce mailing list
> Xfce at

Bob Hepple
mailto:bhepple at
Public Key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the Xfce mailing list