xfwm4 crashes under solaris vnc

James Lee leekk at freeshell.org
Fri Mar 4 22:08:50 CET 2005


I'm trying to run xfce4 under Solaris 2.8 on sparc. It runs fine
under linux also (and also under vnc). It runs fine when run from
the command line in solaris 2.8, but when I do the same under vnc
on the same machine (with vncserver :20), xfwm4 will die, giving
me the following log after a few seconds:

04/03/05 11:10:57 Xvnc version 3.3.tight1.2.8
04/03/05 11:10:57 Copyright (C) 1999 AT&T Laboratories Cambridge.
04/03/05 11:10:57 Copyright (C) 2000-2002 Constantin Kaplinsky.
04/03/05 11:10:57 All Rights Reserved.
04/03/05 11:10:57 See http://www.uk.research.att.com/vnc for information on VNC
04/03/05 11:10:57 See http://www.tightvnc.com for TightVNC-specific information
04/03/05 11:10:57 Desktop name 'X' (everest-himalaya:20)
04/03/05 11:10:57 Protocol version supported 3.3
04/03/05 11:10:57 Listening for VNC connections on TCP port 5920
04/03/05 11:10:57 Listening for HTTP connections on TCP port 5820
04/03/05 11:10:57   URL http://my-machine:5820
input method doesn't support my preedit type (OverTheSpot,Root)

(xfwm4:1347): Pango-WARNING **: Couldn't load font "alexandria Medium 12" falling back to "Sans Medium 12"
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server "unix:20.0"
The application 'xfwm4' lost its connection to the display unix:20.0;
most likely the X server was shut down or you killed/destroyed
the application.
Error: Can't open display: :20
xterm Xt error: Can't open display: :20

I have tried stock vnc and tightvnc.

So, I fired up vnc with fvwm2 as my window manager, used
vncviewer to connect to it and it was ok. Then I go into dummy
mode in fvwm2 and then run xfce4-panel at the command line and it
came up.  But when I tried xfwm4 (or xfwm4 -daemon), it
immediately dies. If I log in at the console and do the same
thing (i.e., use fvwm2, go into dummy, star xfce4), it ws ok.

Does anyone know what is the problem? Is it a problem with vnc or


More information about the Xfce mailing list