no AA fonts in XFce4

Joost Kremers joostkremers at
Wed Jan 21 19:04:27 CET 2004

On Tue, Jan 20, 2004 at 03:17:04PM +0000, Bill Trenker wrote:
> Joost Kremers wrote:
> > i'm probably missing something silly, but i can't find what it is. anyone
> > have a hint?
> I don't know if it's related, but I just went through building and
> installing xfce4 and no fonts showed up anywhere in xfce.  But my other
> GTK+2 apps (abiword, dia) worked fine with fonts.  Then I downloaded
> another GTK+2 app (glade-2) and built it.  That one didn't have any fonts
> showing!  So I knew I had a conflict somewhere and it turned out I had
> two versions of Pango installed.  As soon as I got rid of the library
> files for the old version of Pango, all my GTK+2 apps worked, including
> xfce4.

well, i was quite sure i didn't have two versions of pango, but just to be
sure i gave it a try. i uninstalled version 1.2.5, ran updatedb and did a
'locate pango'. nothing showed up. 'pkg-config --modversion pango' said
there was no package pango installed. trying to start xfce gave a missing
library 'pangox'.

so i'm pretty sure i only have one version of pango installed. ;-)

what does make me wonder, though: if XFce is to use AA fonts, shouldn't it
be linked against pangoxft rather than pangox? both are present on my

Joost Kremers
Life has its moments

More information about the Xfce mailing list