Lost desktop & right mouse

Brian J. Tarricone bjt23 at cornell.edu
Sun Dec 19 09:51:08 CET 2004

Joe Klemmer wrote:

>     Ok, here's my bug report...

/me marks bug INVALID.

>     Upon startup, everything works just fine.  I had some stuff that 
> started from ~/Desktop/Autostart and it all came up nicely.  I tried 
> some of the new config stuff and made sure to disable session 
> management for now.  Then I noticed that the right and middle mouse 
> buttons didn't do anything.
>     I thought it might be something in my autostart interfering so I 
> moved it all out and started a virgin session.  The mouse buttons 
> worked for a little while (say, about 20 seconds) then were gone.
>     I desided to tey running xfdesktop from a term.  I killed the 
> running process and ran xfdesktop.  Things worked fine for about 20 
> seconds then I got errors in the term.  Below are the errors.  The 
> last one just keep repeting about every 10 seconds.  I hope that this 
> has been a useful bug report.
> --------------8<-----------------8<-----------------
> [klemmerj at emperor ~]$ xfdesktop
> ** (xfdesktop:12830): WARNING **: XfceDesktopMenu: Error parsing 
> xfdesktop menu
> file (2): Error on line 88: Entity name 'menu2' is not known

you can't include menus like that anymore.  please take a look at the 
stock menu.xml for instructions (should be installed to 
$sysconfdir/xdg/xfce4/desktop).  also, make sure your menu2.xml is a 
fully-validating XML file, just like the main menu.xml file.


More information about the Xfce mailing list