Having system problems after XFCE4 install!

Andrew Konosky TerranAce007 at comcast.net
Sun Aug 15 02:21:35 CEST 2004

I am running a FC2 system with kernel 2.6.7.-1.494.2.2.

I installed XFCE from source (current CVS) and then added the /etc/X11 
files to put it into the sessions menu, and the desktop works with no 
errors, but my mouse cursor is acting funny now. When I log in for the 
first time on any desktop program, it is fine, but when I log out, the 
cursor is displayed in one spot, but the system thinks it is slightly up 
and to the left or right. It 'moves' differently every time, and I have 
to move the cursor around a button until I see it highlight because just 
pressing it won't work! Sometimes it goes away when I log in, sometimes 
not until I log out, and sometimes I have to restart X to get rid of it, 
but it keeps messing up and is pissing me off!

I tried removing the /etc/X11 entries I made to take XFCE4 out of the 
sessions menu, but that didn't do any good. The only other thing I 
modified was the rpm installation for dbh-1.0. The xffm and xcalendar 
packages wouldn't compile because I didn't have bdh-1.0, but I did an 
rpm -qa|grep bdh and found it was installed, so I unistalled it then 
reinstalled it, then the packages compiled.

For some reason, I don't know if it is related or not, my rcd red-carpet 
daemon just stopped working and started crashing, so I uninstalled and 
reinstalled the rpms, then started the rcd daemon with 
/etc/rc.d/init.d/rcd start, and now it works again...

I hope I didn't screw something up with the XFCE4 install, but I spent 
half an hour compiling the huge amounts of source code, so I don't want 
to uninstall it right away until I figure out what is wrong. How should 
I go about fixing this?

More information about the Xfce mailing list