[Xfce-bugs] [Bug 15090] New: Thunar crashes when opening trash or browsing network

bugzilla-daemon at xfce.org bugzilla-daemon at xfce.org
Sat Jan 26 21:27:14 CET 2019


            Bug ID: 15090
           Summary: Thunar crashes when opening trash or browsing network
    Classification: Xfce Core
           Product: Thunar
           Version: 1.8.2
          Hardware: PC (x86_64)
                OS: Linux
            Status: NEW
          Severity: critical
          Priority: High
         Component: Core
          Assignee: xfce-bugs at xfce.org
          Reporter: rmuncrief at humanavance.com
                CC: benny at xfce.org, hjudt at xfce.org
  Target Milestone: 1.8.3

About a month ago Thunar started crashing when I tried to open the trash or
browse the network. Occasionally the trash will open if it's not empty, but it
always crashes when it is empty. I reinstalled Manjaro and was surprised when
the problem persisted, and then noticed it was happening on my Manjaro server
as well. I also recently installed the latest Manjaro on a friends laptop and
desktop, and the same problem occurs on those systems also. I've temporarily
worked around the problem by installing Nautilus and setting it as the default
file manager. Nautilus works perfectly both opening the trash and browsing the
network, so the problem definitely resides within Thunar. The Thunar version is
displayed as "1.8.1git-480dfc."

To assist in your debugging I created two backtrace files with  "coredumpctl
dump <PID>" and have attached them to this bug report in a single file named
"thunar.crash.core.7z" that contains the two coredumpctl output files.

"thunar.network_browse_crash.core" is relatively short and was taken after
opening Thunar and clicking on "Network", which causes an immediate segfault

"thunar.network_browse_crash.core" is fairly long and was taken after trying to
open the trash, which again cause a segfault. Occasionally a pop up will also
display after the trash crash that says "Failed to execute default File
Manager. Input/output error."

I'm an embedded systems designer, though not a Linux developer. So if you need
any further information or tests please let me know. I love Thunar, and having
to use Nautilus is cumbersome. Thank you for your help and hard work.

You are receiving this mail because:
You are the assignee for the bug.

More information about the Xfce-bugs mailing list