[Xfce-bugs] [Bug 14969] New: Thunar does not recover directories opened in a previous session

bugzilla-daemon at xfce.org bugzilla-daemon at xfce.org
Wed Dec 12 16:34:37 CET 2018


            Bug ID: 14969
           Summary: Thunar does not recover directories opened in a
                    previous session
    Classification: Xfce Core
           Product: Thunar
           Version: 1.8.1
          Hardware: PC (x86_64)
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: General
          Assignee: xfce-bugs at xfce.org
          Reporter: fwjmath at gmail.com
                CC: benny at xfce.org, hjudt at xfce.org
  Target Milestone: 1.8.3

Hardware: Acer TravelMate P2410
OS: Xubuntu 18.10
Running on xfce4, version 4.12, with Thunar, version 1.8.1

On several other desktops environments, I have been using the save session
functionality of xfce to recover my work between shutdowns, especially Thunar
for remembering on which project I am working. With my new laptop, installing
Xubuntu, the problem begins. Saving sessions work well for other applications,
but not Thunar. In Settings -- Sessions and Startup, if I look at the "Session"
Tab, Thunar is never there, even if I opened several directories using it. Then
on startup, none of the directories opened in a previous session appears. I
have had a peek into ~/.cache/sessions. There is no file starting with
"Thunar", which is not the case for my other desktops.

Attempts to fix it reveils that it is probably a problem in Thunar, failing to
write its status to, and to restart from, files written in ~/.cache/sessions,
at least in my case.

Obviously, cleaning the cache in ~/.cache/sessions does not work. Also xfwm4 is
running after startup. Everything is the same for shutdown instead of logout.

First, after startup, there is a "Thunar --daemon" running, and after a bit of
tracking, it was started by systemd upon request of xfdesktop. This instance
writes nothing in ~/.cache/sessions.

Second, when the "Thunar --daemon" from startup is killed, opening an arbitrary
directory give rise to another Thunar daemon instance, which correctly writes
information into ~/.cache/sessions, and also appears in the "Session" Tab of
Settings -- Sessions and Startup. However, if I log out and log back in, the
opened directories are still not there, and we are back to the Thunar daemon
from systemd. I checked that the files in ~/.cache/sessions are clearly intact
between the logout/login using another tty without X.

Therefore, the conclusion seems to be that, somehow on my computer, the Thunar
daemon started by systemd does not work well with session management.

This does not seem to be related to Bug 14509, since there is no coredump for

The laptop is new, and Xubuntu was installed without special options. If there
is anything that may be a problem, it would be that I somehow managed to screw
my home directory to be owned by the root when switching from ext3 to ext4, but
I fixed it myself by chown -R. I mention this because it may also well be a
problem of permission, but when I check, ~/.cache/sessions is well owned by me
with the usual 664 permission on all files in it.

You are receiving this mail because:
You are the assignee for the bug.

More information about the Xfce-bugs mailing list