[Xfce-bugs] [Bug 13947] New: Thunar "executes" non-executable-files

bugzilla-daemon at xfce.org bugzilla-daemon at xfce.org
Sun Oct 22 22:16:51 CEST 2017


            Bug ID: 13947
           Summary: Thunar "executes" non-executable-files
    Classification: Xfce Core
           Product: Thunar
           Version: 1.6.11
          Hardware: PC (x86_64)
                OS: Linux
            Status: NEW
          Severity: minor
          Priority: Low
         Component: Desktop
          Assignee: xfce-bugs at xfce.org
          Reporter: juef17 at hotmail.com
        QA Contact: nick at xfce.org
                CC: benny at xfce.org, hjudt at xfce.org
  Target Milestone: 1.8.0

I had an issue for which I posted on the xfce forums, and the kind moderator
ToZ there helped me a lot. In the end though, he suggested posting here, as
this might very well be a Thunar issue. Relevant discussion is here:


In short:
"I am currently using Winamp 2.95 through Wine, and while it worked beautifully
for months, something suddenly changed. Double-clicking a m3u playlist file
does nothing anymore, but right-clicking it and selecting the default action
works just as expected. I have tried resetting the default "open with"
application, using a custom command, reinstalling Winamp and removing/setting
back its file associations, but to no avail. I'm running 64-bit Linux Lite 3.6,
Thunar 1.6.11-0ubuntu0.16.04.2 and xfce 4.12." The solution to my problem was
that the file was marked as executable, and changing it to non-executable made
it work.

Some command outputs that might be relevant:

francois at SilentPC:~/Desktop$ xdg-mime query filetype Rock.m3u
francois at SilentPC:~/Desktop$ xdg-mime query default audio/x-mpegurl
francois at SilentPC:~/Desktop$ xdg-mime query default $(xdg-mime query filetype

francois at SilentPC:~/Desktop$ cat $(locate wine-extension-miz.desktop)
[Desktop Entry]
Exec=env WINEPREFIX="/home/francois/.wine" wine start /ProgIDOpen Winamp.File

francois at SilentPC:~/Desktop$ xfconf-query -c thunar -lv
/last-details-view-column-widths     50,130,50,50,501,50,50,64,53
/last-details-view-zoom-level        THUNAR_ZOOM_LEVEL_SMALLER
/last-icon-view-zoom-level           THUNAR_ZOOM_LEVEL_NORMAL
/last-separator-position             172
/last-show-hidden                    true
/last-sort-column                    THUNAR_COLUMN_NAME
/last-sort-order                     GTK_SORT_ASCENDING
/last-view                           ThunarCompactView
/last-window-height                  633
/last-window-maximized               false
/last-window-width                   928
/misc-date-style                     THUNAR_DATE_STYLE_ISO
/misc-exec-shell-scripts-by-default  true
/misc-file-size-binary               true
/misc-recursive-permissions          THUNAR_RECURSIVE_PERMISSIONS_ALWAYS
/misc-single-click                   false
/misc-thumbnail-mode                 THUNAR_THUMBNAIL_MODE_NEVER

Also, running Thunar from the terminal and double-clicking the file resulted in
/home/francois/Rock.m3u: 3: /home/francois/Rock.m3u:
Z:homefrancoisMusicMP3sRockACDCACDC: not found
/home/francois/Rock.m3u: 19: /home/francois/Rock.m3u:
Z:homefrancoisMusicMP3sRockACDCACDC: not found
/home/francois/Rock.m3u: 38: /home/francois/Rock.m3u: Syntax error: "("

but as mentioned above, the issue was fixed without modifying the file

Thank you!

You are receiving this mail because:
You are the assignee for the bug.

More information about the Xfce-bugs mailing list