[Xfce-bugs] [Bug 12264] Crash when renaming single file in folder

bugzilla-daemon at xfce.org bugzilla-daemon at xfce.org
Tue Mar 29 19:42:27 CEST 2016


--- Comment #43 from ToZ <tpaulic at hotmail.com> ---
On Emil's prompting, I did some more testing today and found something

With Emil's patch only, the crashing only seems to happen if Thunar is running
in daemon mode (I have "Thunar --daemon) in my startup list. Interestingly, if
I run the Thunar instance through gdb and it crashes, there is no dump or
backtrace (maybe because the Thunar daemon instance crashed?). If I run the
Thunar daemon instance through gdb, it doesn't crash. I tried for a half hour
and no crash. I then took it out of gdb, ran it manually, and on the first
rename, it crashed.

So to recap:
- Emil's patch alone, thunar NOT in daemon mode = no crashing.
- Emil's patch alone, thunar in daemon mode = crashing (not as often today as
every 3rd attempt though - more like every 20th).
- unable to get backtrace, as I can't seem to get Thunar in daemon mode to
crash if running through gdb

You are receiving this mail because:
You are the assignee for the bug.

More information about the Xfce-bugs mailing list