[Thunar-dev] Where can I pass mountoptions

Markus Hofstetter boldoran at gmail.com
Sun Sep 28 22:12:01 CEST 2008

Hi @ll

First I would like to say that I really like Thunar. I have however a little
cosmetic problem with thunar-volman. I have an external western digital
500GB usb hard drive. It worked right out of the box with thunar-volman.
The only problem I have is, that it is formated with ntfs. Volman probably
mounts the drive without any umask option passed to the mount command and as
a result I can only access the files on it as root.

I then added  the following  file in /etc/udev/rules.d/20-customizedusb.rule

BUS=="usb", ATTRS{product}=="External HDD    ",
ATTRS{manufacturer}=="Western Digital ",
ATTRS{serial}=="574341535530333037353735", NAME="%k"
SYMLINK="sdbwd%n",ACTION=="add", RUN+="/user/local/bin/mount-wdhd.sh
ile in /etc/udev/rules.d/

The script I run would of course mount the drive as readable for all users.
I am however afraid that there might be a conflict with volman when both
"programs" try to mount the drive. But i would also like to keep volman
activated for any other usb sticks I might plug in.
But anyway I would prefer to handle the problem with volman directly.
Is there a way to pass mountoptions depending on the filesystem or the   HAL
device UDI or something?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.xfce.org/pipermail/thunar-dev/attachments/20080928/4bb1636e/attachment.html>

More information about the Thunar-dev mailing list