[Thunar-dev] Unable to use fuse-mounted file systems

Tim Tassonis timtas at cubic.ch
Wed May 31 18:11:48 CEST 2006

First of all, thunar is coming along really great and is now my 
preferred file manager. Thanks a lot.

I problem I am hitting now is with fuse filesystems.

I tried isomount and archivemount and on both, thunar refuses to go into 
a directory where such a filesystem is mounted.

Possible reasons:

An archivemount filesystem reports on df:

df: `/home/tit/mnt/_home_tit_cdt.zip': Function not implemented

An strace shows:

statfs("/home/tit/mnt/_home_tit_cdt.zip", 0xbfc5d25c) = -1 ENOSYS 
(Function not implemented)

An isomount reports:

df /home/tit/mnt/fuseiso/debian-testing-i386-netinst.iso
Filesystem           1K-blocks      Used Available Use% Mounted on
fuseiso                      0         0         0   -  \

Could this be worked around in thunar or has thunar the opinion that 
these calls have to return sane data?


More information about the Thunar-dev mailing list