[Thunar-dev] Libexo build error

Brian brian-schott at cox.net
Sat Sep 3 23:04:57 CEST 2005

Been a while since I've said anything here, mostly due to a lack of free 
time. Anyways, I  tried checking out libexo and thunar today to give 
them a try and ran into a problem running "make" on libexo. The exact 
error message is as follows:

Making all in exo-csource
make[2]: Entering directory `/home/alaran/src/libexo/exo-csource'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DG_LOG_DOMAIN=\"exo-csource\" 
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include   -g -O2 -O0 -g3 
-DG_DISABLE_DEPRECATED -Werror -Wall -fvisibility=hidden -MT 
exo_csource-main.o -MD -MP -MF ".deps/exo_csource-main.Tpo" -c -o 
exo_csource-main.o `test -f 'main.c' || echo './'`main.c; \
then mv -f ".deps/exo_csource-main.Tpo" ".deps/exo_csource-main.Po"; 
else rm -f ".deps/exo_csource-main.Tpo"; exit 1; fi
main.c: In function `print_csource':
main.c:158: warning: unsigned int format, different type arg (arg 5)
make[2]: *** [exo_csource-main.o] Error 1
make[2]: Leaving directory `/home/alaran/src/libexo/exo-csource'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/alaran/src/libexo'
make: *** [all] Error 2

The line it chokes on is:
g_fprintf (fp, "%sconst unsigned %s_length = %uu;\n", gen_linkage, 
gen_varname, length);

I'm using glib 2.6.4, and I ran configure as follows: "./configure 
--prefix=/usr/ --enable-maintainer-mode"

More information about the Thunar-dev mailing list