[Thunar-dev] Problems building new Thunar snapshot

Benedikt Meurer benedikt.meurer at unix-ag.uni-siegen.de
Wed Nov 9 22:38:14 CET 2005

Erik Harrison wrote:
>>#define _XOPEN_SOURCE 500
>>to the top of tdb.c and check if that fixes the problem.

Somehow my last mails don't show up on the mailinglist, so I CC you,
just to be sure.

> Indeed, it does fix the problem building tdb. I should have done that myself.
> In file included from ../thunar-vfs/thunar-vfs-info.h:28,
>                  from ../thunar-vfs/thunar-vfs.h:27,
>                  from thunar-vfs-enum-types.c:6:
> ../thunar-vfs/thunar-vfs-mime-info.h: In function `thunar_vfs_mime_info_ref':
> ../thunar-vfs/thunar-vfs-mime-info.h:83: warning: implicit declaration
> of function `exo_atomic_inc'
> make[3]: *** [libthunar_vfs_1_la-thunar-vfs-enum-types.lo] Error 1
> make[3]: Leaving directory `/home/erik/tmp/Thunar-0.1.3svn-r00136/thunar-vfs'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/home/erik/tmp/Thunar-0.1.3svn-r00136/thunar-vfs'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/erik/tmp/Thunar-0.1.3svn-r00136'
> make: *** [all] Error 2
> Is my exo version out of date?

I was wondering how you were able to build libexo, because it also uses
G_INLINE_FUNC. Nevertheless, its outdated.

>>>Building with --disable-debug bypasses all of that, and compilation
>>>succeeds, but then I get a lot of linker errors.
>>>.libs/libthunar_vfs_1_la-thunar-vfs-job.o(.text+0x0): In function
>>>/usr/include/glib-2.0/glib/gutils.h:247: multiple definition of `g_bit_nth_lsf'
>>Meh. Somehow your compiler/linker combo doesn't handle extern inline
>>functions properly. What versions of gcc/binutils do you use?
> binutils 2.15
> GCC 3.4.3 and I also tried 3.3.4

Hm, I have 3.4.2/2.15 here (though not 100% upstream versions). It even
worked on Debian/testing (3.3.x/2.15 IIRC), so it's weird that it
doesn't work for you. Can you send me your glibconfig.h?


More information about the Thunar-dev mailing list